How to install Windows Phone SDK with XNA support in Windows 8

A common problem for Windows Phone developers moving to Windows 8 is the support for XNA. XNA is not part of the “Metro” types of apps, but you can still develop XNA using Windows 8 (like you do in Windows 7). Installing the SDK directly in Windows 8 will make the XNA part of the installation to fail.

The solution is very simple. Make sure you have the latest version of Games for Windows Marketplace Client installed.

Follow these steps to install Windows Phone SDK 7.1.1 with XNA on Windows 8:

1. Install Games for Windows Marketplace Client
http://xbox.com/en-us/live/pc/downloadclient

2. Install Windows Phone 7.1 SDK
https://dev.windowsphone.com/en-us/downloadsdk

3. Install Windows Phone 7.1.1. SDK Update
https://dev.windowsphone.com/en-us/downloadsdk

 

Enjoy! Smilefjes

image

About these ads
This entry was posted in Windows 8, Windows Phone. Bookmark the permalink.

6 Responses to How to install Windows Phone SDK with XNA support in Windows 8

  1. Trent says:

    Putting Windows Phone 7 SDK on Windows 8 is a waste of time.
    The version 8 SDK will be released soon and it features native C++/CLI support.
    A major step in right direction for MS. Prior to Windows Phone 8, one could not import non C# code into Windows Phone 7, having one rewrite routines commonly available such as SIP protocol.

    • digitalerr0r says:

      I disagree that installing XNA on Windows 8 is a waste of time considering the huge amount of games and XNA Projects existing on Windows Phone 7 that needs to be maintained and updated. But yes, 8 will be great 😉

      • Andrew Birch says:

        I believe the Windows Phone 8 SDK will include all of the 7.1.1 SDK in it too, so the above commenter is probably correct, you don’t need to install the 7.1.1 SDK if you just wait for the WP8 SDK, you can develop for both platforms, including XNA for 7.1.1 projects.

  2. It’s not waste of time, with this solution, you can develop both metro and wp apps in Win8, and do not have to wait another month for stupid microsoft to release their “precise” WP8 SDK.

  3. SuNcO says:

    I see this workaround on another site and still not working for me :(

  4. Ryan says:

    Well, here we are over a year later, and guess what, you still need to install this and the WP 7 SDK if you need to support legacy XNA apps. Thanks for the info,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s